Blog

【Mac】eclipse 4.3 + PDT + symfonyプラグインをインストールしました

2013.12.12Cat:その他 プログラマー

この前までは、eclipse 3.7を2年ほど使っていました。
最近になって、頻繁にIDEエラーが発生するようになって、更新(eclipseのcheck for update)もできないから、最新のeclipseをインストールすることを決意しました。

インストール手順

eclipseから、Eclipse IDE for Java EE Developersをダウンロードします。
あとは、下記を参照しながら、日本語化を除き、インストールを完成しました。
http://slumbers99.blogspot.jp/2012/11/php-eclipse.html
http://qiita.com/himagurashi/items/a8502de376cb606c5dc9

エラー対応

Annotationが認識されない

エラーログビューに下記エラーが出てました。

いろいろ調べた結果、org.antlr.runtimeが古いのが原因のようです。AURで最新のものをダウンロードして解決いたしました。

namespaceが認識されない

この記事をヒントに、symfony builderを使って.projectを書き直してみました。

※aspectPHPプラグインを削除して、namespaceが認識されるようになったから、上記をやらなくてもいいのようです。

ファイルを変更するたびにIDEエラーが出る

こちらもいろいろ調べたあげく、aspectPHPプラグインのバグが原因のようで、eclipseからそれをuninstallしてからこの現象が解消しました。

まとめ

やっていいと思うこの

失敗したこと

  • 手間を省くのため、あえて「Eclipse IDE for Java EE Developers」をダウンロードしたのに、かえて調査に手間かかった(Eclipse IDE for Java EE Developersパッケージのeclipse-antlr-runtimeが古いから?)
  • 日本語化ができるかが検証できていない(eclipse-antlr-runtimeの原因か、pleiadesプラグインの原因か、結局きちんと検証できなかった)
  • PDT Extension Groupから最新のものをほぼすべてをインストールしないと、エラーが発生する(これもeclipse-antlr-runtimeの原因かもしらない)
  • aspectPHPプラグインが使えない
  • 古い.metadataの一部(org.eclipse.dltk.core.index.sql.h2と com.dubture.symfony.indexなど)が最新のものとコンフリクトするから、バックアップを取って削除すべく

Author Profile

jeff_maj
システムエンジニア/1984年生/上海交通大学卒/Webサービス/EC/iphone/android
» 投稿一覧
  • Launch Cart次世代ECサイト構築システム 初期月額無料
  • LaunchMovie ECに特化した動画制作サービス

Archive

ページTOPへ